debuggers.hg

changeset 22707:9b0b2233f2e6

ocaml: add dependency to module metadata

Signed-off-by: Ian Campbell <ian.campbell@citrix.com>
Committed-by: Ian Jackson <ian.jackson@eu.citrix.com>
author Ian Campbell <ian.campbell@citrix.com>
date Thu Jan 06 17:33:39 2011 +0000 (2011-01-06)
parents 21ee14d775ff
children 2e1bd6baee28
files tools/ocaml/libs/eventchn/META.in tools/ocaml/libs/log/META.in tools/ocaml/libs/xb/META.in tools/ocaml/libs/xc/META.in tools/ocaml/libs/xs/META.in
line diff
     1.1 --- a/tools/ocaml/libs/eventchn/META.in	Thu Jan 06 17:33:00 2011 +0000
     1.2 +++ b/tools/ocaml/libs/eventchn/META.in	Thu Jan 06 17:33:39 2011 +0000
     1.3 @@ -1,4 +1,5 @@
     1.4  version = "@VERSION@"
     1.5  description = "Eventchn interface extension"
     1.6 +requires = "unix"
     1.7  archive(byte) = "eventchn.cma"
     1.8  archive(native) = "eventchn.cmxa"
     2.1 --- a/tools/ocaml/libs/log/META.in	Thu Jan 06 17:33:00 2011 +0000
     2.2 +++ b/tools/ocaml/libs/log/META.in	Thu Jan 06 17:33:39 2011 +0000
     2.3 @@ -1,4 +1,5 @@
     2.4  version = "@VERSION@"
     2.5  description = "Log - logging library"
     2.6 +requires = "unix"
     2.7  archive(byte) = "log.cma"
     2.8  archive(native) = "log.cmxa"
     3.1 --- a/tools/ocaml/libs/xb/META.in	Thu Jan 06 17:33:00 2011 +0000
     3.2 +++ b/tools/ocaml/libs/xb/META.in	Thu Jan 06 17:33:39 2011 +0000
     3.3 @@ -1,4 +1,5 @@
     3.4  version = "@VERSION@"
     3.5  description = "XenBus Interface"
     3.6 +requires = "unix,mmap"
     3.7  archive(byte) = "xb.cma"
     3.8  archive(native) = "xb.cmxa"
     4.1 --- a/tools/ocaml/libs/xc/META.in	Thu Jan 06 17:33:00 2011 +0000
     4.2 +++ b/tools/ocaml/libs/xc/META.in	Thu Jan 06 17:33:39 2011 +0000
     4.3 @@ -1,4 +1,5 @@
     4.4  version = "@VERSION@"
     4.5  description = "Xen Control Interface"
     4.6 +requires = "mmap,uuid"
     4.7  archive(byte) = "xc.cma"
     4.8  archive(native) = "xc.cmxa"
     5.1 --- a/tools/ocaml/libs/xs/META.in	Thu Jan 06 17:33:00 2011 +0000
     5.2 +++ b/tools/ocaml/libs/xs/META.in	Thu Jan 06 17:33:39 2011 +0000
     5.3 @@ -1,4 +1,5 @@
     5.4  version = "@VERSION@"
     5.5  description = "XenStore Interface"
     5.6 +requires = "unix,xb"
     5.7  archive(byte) = "xs.cma"
     5.8  archive(native) = "xs.cmxa"