debuggers.hg

changeset 3353:fbfa79f89dfa

bitkeeper revision 1.1159.187.75 (41c98e1cJF7FTRAcKrESOThaChSpOQ)

Check for a recent GCC version before building Xen.
author kaf24@scramble.cl.cam.ac.uk
date Wed Dec 22 15:09:16 2004 +0000 (2004-12-22)
parents 391b2a76a749
children 5855ed6e8243
files xen/arch/x86/Rules.mk
line diff
     1.1 --- a/xen/arch/x86/Rules.mk	Wed Dec 22 11:00:58 2004 +0000
     1.2 +++ b/xen/arch/x86/Rules.mk	Wed Dec 22 15:09:16 2004 +0000
     1.3 @@ -32,3 +32,20 @@ CFLAGS  += -m64 -mno-red-zone -fpic -fno
     1.4  CFLAGS  += -fno-asynchronous-unwind-tables
     1.5  LDFLAGS := --oformat elf64-x86-64
     1.6  endif
     1.7 +
     1.8 +# Test for at least GCC v3.2.x.
     1.9 +gcc-ver = $(shell $(CC) -dumpversion | sed -e 's/^\(.\)\.\(.\)\.\(.\)/\$(1)/')
    1.10 +ifeq ($(call gcc-ver,1),1)
    1.11 +$(error gcc-1.x.x unsupported - upgrade to at least gcc-3.2.x)
    1.12 +endif
    1.13 +ifeq ($(call gcc-ver,1),2)
    1.14 +$(error gcc-2.x.x unsupported - upgrade to at least gcc-3.2.x)
    1.15 +endif
    1.16 +ifeq ($(call gcc-ver,1),3)
    1.17 +ifeq ($(call gcc-ver,2),0)
    1.18 +$(error gcc-3.0.x unsupported - upgrade to at least gcc-3.2.x)
    1.19 +endif
    1.20 +ifeq ($(call gcc-ver,2),1)
    1.21 +$(error gcc-3.1.x unsupported - upgrade to at least gcc-3.2.x)
    1.22 +endif
    1.23 +endif